Opened 15 months ago

Closed 5 months ago

#1769 closed defect (fixed)

DHCP - Dynamic DNS update does not work

Reported by: foxi352 Owned by: phenigma
Priority: minor Milestone: 1204
Component: global Version: 1204
Severity: normal Keywords:
Cc:

Description

DHCP server can apparently not update DNS entries dynamically. That may be a problem because it's an upgraded 10.04. Not sure.

May  5 10:23:04 dcerouter dhcpd: Unable to add forward map from AppleTV-4.swa.local to 192.168.80.141: timed out

Attachments (3)

Network_Bind.sh.perms.10-04.diff.txt (376 bytes) - added by mkbrown69 7 months ago.
Permissions patch
dhcpd.conf.tmpl.diff.1204.txt (393 bytes) - added by mkbrown69 6 months ago.
Patch to dhcpd.conf template
Network_Bind.sh.diff.1204.txt (3.2 KB) - added by mkbrown69 6 months ago.
patch to Network_Bind.sh

Download all attachments as: .zip

Change History (14)

comment:1 Changed 15 months ago by foxi352

The problme seems that dhcpd does not have access to the bind zone files. The problem may be solved with the following, TBC the next days.
Add user dhcpd to the bind group:

usermod -a -G bind dhcpd

Change permission on lmce zone files:

chmod 664 /var/cache/bind/*

If this is confirmed working it should be added somewhere in a script. Best location has to be determined.

comment:2 Changed 15 months ago by foxi352

:-( Seems still some rdnc key problem or whatever ...

comment:3 Changed 12 months ago by foxi352

  • Component changed from unknown to global
  • Summary changed from Dynamic DNS update does not work to DHCP - Dynamic DNS update does not work

comment:4 Changed 11 months ago by phenigma

Is apparmor starting correctly? apparmor should be giving dhcpd access to the required bind directory

comment:5 Changed 8 months ago by Alblasco1702

Is the RDNC key used in dhcp the right key, looks like the key is wrong.

comment:6 Changed 7 months ago by mkbrown69

Ok, a few comments on this. First, this issue currently affects 10.04 as well as 12.04. It likely came about from the bind8 to bind9 transition during the 7.04 to 10.04 upgrade. The LMCE code wasn't fully updated for bind9 syntax.

I have it working on my system now (10.04). I'm going to have to fix the zone file creation code in /usr/pluto/bin/Network_Bind.sh to generate proper zone files, and I'll post the diffs when I get them finished and fully tested.

There are also permission problems on the zone files and directory. /var/cache/bind needs a chmod g+s applied to it and the files within it need a chmod 664 * as per the above. The usermod for the dhcpd user is also required. I'll incorporate those into the script fixes as well. Hopefully will get that script fixed and the diffs posted this week.

HTH!

/Mike

comment:7 Changed 7 months ago by mkbrown69

Adding a patch to fix permissions. diffed against 10.04, but pertains to 12.04 also.

Changed 7 months ago by mkbrown69

Permissions patch

comment:8 Changed 6 months ago by mkbrown69

Disregard previous patch titled Network_Bind.sh.perms.10-04.diff.txt. The issue was more complicated, and the perms weren't the core issue. Patches done and pending against bind and dhcp configurations. Just finishing up some soak testing.

HTH!

/Mike

Changed 6 months ago by mkbrown69

Patch to dhcpd.conf template

Changed 6 months ago by mkbrown69

patch to Network_Bind.sh

comment:9 Changed 6 months ago by mkbrown69

patches to dhcpd and Network_Bind.sh to enable dynamic DNS updates from dhcpd. Includes syntax checking of bind zones and includes an mx record for the core.

/Mike

comment:10 Changed 5 months ago by phenigma

  • Owner set to phenigma

comment:11 Changed 5 months ago by phenigma

  • Resolution set to fixed
  • Status changed from new to closed

In [28704] Refs #1769 - fixes for DDNS on 1204, thanks mkbrown69! Once someone else tests and confirms it can be backported to 1004.

Note: See TracTickets for help on using tickets.